syntax question (Re: CVS: commit tomas_f abi/src/wp/ap/xp ap_EditMethods.cpp ap_Menu_ActionSet.cpp ap_Menu_Functions.cpp ap_Menu_Functions.h ap_Menu_Id_List.h ap_Menu_Layouts_MainMenu.h ap_String_Id.h

From: Hubert Figuiere <hfiguiere_at_teaser.fr>
Date: Sun Dec 11 2005 - 00:48:54 CET

I have question:

> +Defun1(toggleDomDirectionSect)
> +{
> + CHECK_FRAME;
> + ABIWORD_VIEW;
> +
> + const XML_Char * properties[] = { "dom-dir", NULL, 0};
> + const XML_Char drtl[] = "rtl";
> + const XML_Char dltr[] = "ltr";

Why not using

const XML_Char *drtl = "rtl";
const XML_Char *dltr = "ltr";

> +
> + fl_BlockLayout * pBl = pView->getCurrentBlock();
> + UT_return_val_if_fail( pBl, false );
> +
> + fl_DocSectionLayout * pSL = pBl->getDocSectionLayout();
> + UT_return_val_if_fail( pSL, false );
> +
> + if(pSL->getColumnOrder())
> + {
> + properties[1] = static_cast<const XML_Char *>(&dltr[0]);

And then removing the static_cast here?

Not that it really matters, but it make the code easier to read...

So I was wondering if you had any reason (to make me hate C/C++ even more)

Hub
Received on Sun Dec 11 00:48:19 2005

This archive was generated by hypermail 2.1.8 : Sun Dec 11 2005 - 00:48:19 CET